1

Since several days ago (something automatically upgraded), I get no sound out of my Lenovo Thinkpad 470s laptop model 20HFCTO1WW with Ubuntu 18.04. I tried several things other similar threads suggested:

pacmd list-cards

returns 0 cards

lspci -nnk | grep -A2 Audio

returns nothing, and

pulseaudio -k && sudo alsa force-reload

and rebooting does nothing. There are many posts about this all over the interwebs but no solution work for me.

Q1: How do I get my sound back?

Q2: This seems like a fairly catastrophic defect that's not getting enough publicity -- does anyone know what happened in apt-get upgrade to have caused this? Is it "a part of the package" associated with a FOSS OS, i.e. its instability? As much as I dislike Windows, I can't recollect anything similar ever happening.

UPDATE 1: Ubuntu just auto-updated and the details of the update indicated Thinkpad-related updates. After that, the Settings don't show dummy output anymore and pacmd list-cards and lspci -nnk | grep -A2 Audio are no longer empty, however, there is still no sound coming out.

UPDATE 2: After removing the pulse config (https://askubuntu.com/questions/1133074/after-dummy-sound-output-got-fixed-by-ubuntu-update-speakers-work-but-not-headp), I get sound but only coming out of the speakers. When I plug my headphones, I get no sound.

UPDATE 3: I lost sound again, only Dummy Output showing in Settings.

  • My laptop S/N is PC0LRK1T, it's a T470, about 2 yrs old. I will do the bootable USB tomorrow – amphibient Apr 10 at 4:08
  • What happens when you boot from a howtogeek.com/howto/linux/… ? Please click edit and update your question with the information we will need to solve this. – K7AAY Apr 10 at 16:28
  • I just booted from a newly created USB, got brand new Ubuntu for the time being, however still no sound (dummy output). – amphibient Apr 11 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.