1

win10 laptop with both ssd & hdd unmountable. I booted with live-debian and copied hdd with safecopy in an .img-file on external usb hdd. This worked, 100% copied, no bad blocks, no unrecoverable blocks, say's safecopy.

That is the output of file :

/media/tom/My Book/mdat.img: `DOS/MBR boot sector; partition 1 : ID=0xee, start-CHS (0x0,0,2), end-CHS (0x3ff,255,63), startsector 1, 976773167 sectors, extended partition table (last)`

This is from fdisk :

Command (m for help): p
Disk /media/tom/My Book/mdat.img: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 4AAA6B26-E1FC-4335-BBF3-9456FC4F35C9

Device                       Start       End   Sectors   Size Type
/media/tom/My Book/mdat.img1  2048 976771071 976769024 465.8G Microsoft basic data

Then I tried :

    losetup -f --show -o 1048576 --sizelimit 976769024 mdat.img
/dev/loop0

mount -t ntfs-3g /dev/loop0 /mnt/meldat/
NTFS signature is missing.
Failed to mount '/dev/loop0': Das Argument ist ungültig
The device '/dev/loop0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

where do i go wrong ?

edit:

I tried gdisk as well, same result in the end :

gdisk mdat.img
GPT fdisk (gdisk) version 1.0.1

The protective MBR's 0xEE partition is oversized! Auto-repairing.

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): i
Using 1
Partition GUID code: EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 (Microsoft basic data)
Partition unique GUID: 66AD43C4-69FF-4274-B121-07462B71A1F1
First sector: 2048 (at 1024.0 KiB)
Last sector: 976771071 (at 465.8 GiB)
Partition size: 976769024 sectors (465.8 GiB)
Attribute flags: 0000000000000000
Partition name: 'Basic data partition'
  • Nowadays there's often no need to play with losetup -o, mount can handle this: mount -o offset=$((2048*512)) …. I think you set --sizelimit wrong (you gave sectors instead of bytes; maybe your losetup is different than mine), but I'm not really sure this is the culprit. You said HDD was unmountable; so maybe the filesystem is corrupt and for this reason the image is unmountable. – Kamil Maciorowski Apr 9 at 10:30
  • Thank you for you're answer. you are right, i had wrong sizelimit, but even with correct(500'106'788'352) or with "mount -o loop,offset=1048576 mdat.img /mnt/meldat/" it did not work. – Tom Apr 9 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.