0

I'd like to install PHP for Litespeed on Linux Mint.

After I run: sudo apt install lsphp72 lsphp72-curl lsphp72-imap lsphp72-mysql lsphp72-intl lsphp72-pgsql lsphp72-sqlite3 lsphp72-tidy lsphp72-snmp I receive the error:

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: lsphp72 : Depends: libjpeg62-turbo (>= 1.3.1) but it is not installable Depends: libpng12-0 (>= 1.2.13-4) but it is not installable lsphp72-intl : Depends: libicu52 (>= 52~m1-1~) but it is not installable lsphp72-tidy : Depends: libtidy-0.99-0 but it is not installable E: Unable to correct problems, you have held broken packages.

My /etc/apt/sources.list.d/lst_debian_repo.list contains

deb http://rpms.litespeedtech.com/debian jessie main

Why can't I install the dependencies?

1

On Linux Mint, the jessie repositories aren’t appropriate; assuming you’re running Linux Mint 19 or later, you need to use

deb http://rpms.litespeedtech.com/debian bionic main

as your repository.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.