0

While creating a haproxy_check user in MariaDB I am getting error ERROR 1364 (HY000): Field 'ssl_cipher' doesn't have a default value, what I need to do?

  • You are inserting data into a table but fail to give data for all fields. If you are doing this manually, make sure to specify values for all fields that does not have default values. – Kusalananda Apr 8 at 8:25
  • I would advise investing more time in writing questions. I talking about an error, you will get better answers describing the operation that led to that error. – Rui F Ribeiro Apr 8 at 9:11
0

It's likely you are running mariadb with ssl enabled but don't have a cipher set. You have two options;

  • start the server without ssl enabled if you don't require encrypted connections (remove the -ssl flag from the config options)
  • set the ssl_cipher variable. See the documentation for a more complete picture.

Thanks

S

  • Thanks for the information. – Aftab Ali Apr 8 at 10:46
  • if anybody facing the same issue, use the following commands on MariaDB or MySQL alter table user change column ssl_cipher ssl_cipher blob null ; alter table user change column x509_issuer x509_issuer blob null ; alter table user change column x509_subject x509_subject blob null ; alter table user change column authentication_string authentication_string blob null ; – Aftab Ali Apr 10 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.