0

I recently re-purposed an old laptop of mine by popping in a new SSD and installing the latest stable version of Linux Lite.

I've been trying to get my preferred configuration of Atom running on it. Every thing has gone smoothly except getting LaTeX beautify to work which requires latexindent.pl. When I try to run latexindent.pl it complains that I do not have Log4perl.

When I type cpan install Log::Log4perl in the terminal it fails on the following error. This always occurs after passing all the tests. The last thing the terminal prints before this error is Magnifying 23 pod documents

I have also tried to do the following (all result in the same error)

  • Running with sudo in front of the commands
  • Entering the cpan shell and running it from there
  • Using the -f (force install) and -T (skip tests) options
  • Downloading the Log4perl module directly and installing it manually

!!!!!!!!!!!!!!

ERROR: Can't create 'usr/local/man/man1'

mkdir /usr/local/man: File exists at /usr/share/perl/5.26/ExtUtils/Install.pm line 477

!!!!!!!!!!!!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.