0

The latest release of Brackets (v1.13) is not available in the AUR. So I downloaded the official .deb package from the official site. Now how do I go about installing it ? Do I have to write a PKGBUILD? I won't know it's dependency and all. I have converted it to an arch package with Debtap. But pacman -U <Convertedpackage.tar.xz> throws unresolvable dependency for the following:

     warning: cannot resolve "libudev>=147", a dependency of "brackets"
     warning: cannot resolve "lsb-base>=3.2", a dependency of "brackets" 

How should I go about this ?

3
  • Convert to a tar.gz file using alien. Then extract in a directory, check the binaries with ldd to make sure you have what they need, and then move files/directories around as needed. Personally I'd put 'em under /opt and manually link binaries, etc to appropriate places under /usr or /usr/local
    – ivanivan
    Commented Apr 7, 2019 at 15:09
  • @ivanivan , is it working for you ? Commented Apr 7, 2019 at 16:11
  • no, I use Debian and Mint, so ... But this is how I've used packages from other distros successfully in the past.
    – ivanivan
    Commented Apr 7, 2019 at 16:13

1 Answer 1

1

It seems Brackets 1.13 have some issues on arch linux. There are two provider for Brackets 1.12 in AUR and both have been flagged old because v1.13 was released more than six months ago.

link- http://blog.brackets.io/2018/06/18/brackets-1-13-is-now-available/

I should have checked the pinned comment by the maintainer.

link - https://aur.archlinux.org/packages/brackets-bin/

Also this. http://github.com/adobe/brackets/issues/14485

So, currently, Brackets 1.13 breaks down in arch Linux and they are waiting for the fix from upstream.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .