-1

This question already has an answer here:

I recently installed trisquel on my computer. When I decided to use the terminal and sudo I was prompted to use a password despite the fact that I set a blank one.

I want to know what I am supposed to type then.

I am open to going into grub and somehow replacing the password.

I have tried out pressing enter at the terminal to no avail.

I am the root user and cannot make changes without the password.

marked as duplicate by Rui F Ribeiro, Stephen Harris, muru, GAD3R, Haxiel Apr 7 at 7:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Just hit the ENTER key when prompt to a password. Or you can supply it like:

echo -e '\n' | sudo -S ls
  • Did you actually try this? sudo does not read the password from standard input. – Johan Myréen Apr 6 at 6:03
  • Sorry. It didn't work. – Kennichi Nitta Apr 6 at 6:11
  • Yes, I tried @JohanMyréen. The -S flag is exactly to read the password from standard input as stated by the manual. If entering an empty password isn't working I'd suggest then to change it. Boot your computer in single mode user (askubuntu.com/questions/132965/…) , that will get you a shell as root. Then passwd nitta (supposing your username is nitta) would do the trick – Frederico Oliveira Apr 6 at 6:56
  • @FredericoOliveira I'll try that out and report back – Kennichi Nitta Apr 6 at 22:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.