0

I installed chromium on Debian Stretch to work with no Desktop Environment. It worked but annoying margins appeared at the top and the right of the screen. They are about 50px wide. (The screen is 1280/1024). This margins are black stripes of a terminal so there is no X graphic there. It looks like the whole window is moved by a vector [50, 50]

When I put midori instead of chromium the margins do not appear.

Here you are the configuration:

s@14march:~$ cat ~/.bash_profile
if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then
    startx
fi
s@14march:~$ 

s@14march:~$ cat ~/.xinitrc
#!/bin/sh
xset -dpms
xset s off
xset s noblank

unclutter &
chromium http://google.pl/ --kiosk --window-size=1280,1024 --start-fullscreen --incognito --noerrdialogs --disable-translate --no-first-run --fast --fast-start --disable-infobars --disable-features=TranslateUI --disk-cache-dir=/dev/null
s@14march:~$ 

How to remove the margins?

0

This is the answer --window-position=0,0

In the file ~/.xinitrc:

s@14march:~$ cat ~/.xinitrc
#!/bin/sh
xset -dpms
xset s off
xset s noblank

unclutter &
chromium http://google.pl/ --kiosk --window-position=0,0 --window-size=1280,1024 --start-fullscreen --incognito --noerrdialogs --disable-translate --no-first-run --fast --fast-start --disable-infobars --disable-features=TranslateUI --disk-cache-dir=/dev/null
s@14march:~$ 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.