-1

Back in 2015, I got an Asus VivoPC-VM62N with Windows preinstalled. I ran gparted (gnu partition editor) on it, shrank the Windows partition, and used the freed-up space for several linux partitions plus swap. I installed Slackware 14.1x64 (current at that time) on one of the linux partitions, and it's been dual-booting fine between win and slack since then.

Now I've just installed Slackware 15.0x64 (actually slackware64-current, but it introduces itself as 15.0 on its Welcome screen) on one of the other linux partitions, with the intention of triple-booting among all three. But it apparently doesn't like those "threesomes":)...

Before writing a boot record, the Slackware install said it detected uefi, and asked if I'd rather write a slackware option on the uefi boot menu. I'd originally answered "yes" for the 14.1 install back in 2015, and that worked fine. And so that's what I did again during the 15.0 install.

But this time the install script then said it detected another slackware boot option, and asked if I wanted it deleted first, which is what it recommended. But I answered "no", intending to boot 14.1 and 15.0. So it proceeded, presumably as requested, but I noticed a very brief error message flash by, saying something like "duplicate block address" or something like that (sorry, not sure exactly).

When I rebooted after completing the install, I first pressed Del to enter setup, hoping to rearrange the boot priority selection. But there was only one Slackware option along with Windows, not the two Slackwares I'd hoped for. (place your bets now -- did it boot 14.1 or 15.0?)

And that one Slackware option booted 15.0 (winner, winner, chicken dinner:), which is now dual-booting fine along with Windows. But 14.1 seems inaccessible. The partition's still there, entirely undamaged, and can be mounted. Its /boot/efi/ and /boot/elilo stuff also seems to be all there and unchanged. But I can't figure out how to boot it.

Is there some way to "manually" add a boot-that-partition option to the uefi boot menu, and in such a way that setup recognizes it on its boot priority screen?

  • 1
    Yes, it's possible to do that manually. Please add the output of efibootmgr -v and tell us the partition (/dev/sdaX) of your Slackware 14.1 installation. – Freddy Apr 5 at 5:44
  • @Freddy Thanks. Don't know how I missed efibootmgr while trying to google a solution before posting, but I apparently managed to miss it. And I think I can figure the rest out from there. Post "efibootmgr" as a one-word answer, and I'll check it. (Maybe you can win a prize as shortest checked answer of the month.) – John Forkosh Apr 5 at 7:26
1

If your partition is /dev/sda2, it should be a command like

efibootmgr --create --disk /dev/sda --part 2 --label "Slack14.1" --loader \\EFI\\Slackware\\elilo.efi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.