2

I'm using manjaro linux based arch with kde plasma desktop. I updated the system with sudo pacman -Syu, after that i rebooted my laptop booted into the system but the kde desktop doesn't showed up just black screen with the cursor. But if i run any program from the terminal, the program starts normaly, i tried some basic solution but with no result:

  1. reinstall kde plasma.

  2. install gnome desktop to figure out if the problem is related to kde only or something else, guess what?gnome desktop also stucked and booted up with black screen.

  3. reinstall qt packages.

  4. reinstall xorg.

  5. Delete.cache folder. I can't figure out how to fix this issue or what cause this.
  • Can you try restarting plasma? Sometimes I have to do this after logging in. First kill it with kquitapp5 plasmashell, then start with plasmashell. If the first command won't kill it, then try pkill -x plasmashell. If that doesn't work try pkill -x -9 plasmashell. Then start it again. – Sparhawk Apr 4 at 11:37
  • The When i trying to kill it with your first command i get that error "Application plasmashell couldn't be found using service org.kde.plasmashell and path /MainApplication" – mohamed maher Apr 4 at 12:56
  • And the others? – Sparhawk Apr 4 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.