15

I have been using the gTile Gnome shell extension. In gTile, I defined specific preset window positions, along with the keyboard shortcuts Super+1, Super+2, etc. to apply them. This was all working fine until a recent update of Gnome. After the update, some of my shortcuts now seem to do other random things, while other shortcuts don't seem to do anything at all.

I looked in Settings → Devices → Keyboard → Keyboard Shortcuts, but the Super+1, Super+2 shortcuts didn't even seem to be defined. I also uninstalled all other Gnome shell extensions (thinking that other extensions might be setting their own shortcuts) but that didn't help.

Why are these shortcuts un-remappable and how can I make them remappable again?

2
  • askubuntu.com/q/968103/42720 Commented May 15, 2022 at 2:22
  • It would be so nice to have a way to remap those conveniently directly from the dock - ideally not matching the slot but the application itself (e.g. Super+F for Firefox, Super+T for Thunderbird, Super+G for Gedit/Geany...). It would be a the ideal replacement for the clumsy and sometimes buggy script I currently use with custom shortcuts.
    – dreua
    Commented Jan 9, 2023 at 12:19

2 Answers 2

36

It turns out that some keyboard shortcuts in Gnome do not show up in Settings → Devices → Keyboard → Keyboard Shortcuts. These "hidden" shortcuts are accessible by using the dconf-editor command. In the dconf editor, the Super+1 remapping was found at

org/gnome/shell/keybindings/switch-to-application-1

while remappings for Super+2, Super+3, etc. were found at similar locations. By clearing these mappings I was able to redefine my own.

enter image description here

*related question

3
  • 1
    Thank you! Simply setting these to default (right click, Set Default) made it so I can use Super+1, 2, etc. again. Tested on Pop!_OS 20.10. Commented Dec 28, 2020 at 16:58
  • Thanks a lot, this was driving me crazy. The funny thing is that there are apparently the same defaults for all of Super+1, Super+2 etc, but only 2 didn't work for me, i.e. it always was consumed by the shell itself instead of switching to the second workspace, while my custom screenshots did work for the other workspaces. Still no idea why, but at least I could make it work by resetting the value of this one to [].
    – VZ.
    Commented Dec 25, 2021 at 23:45
  • It's a lot of clicking to clear these settings. Use this command to clear them all at once: for i in {0..9}; do dconf write "/org/gnome/shell/keybindings/switch-to-application-$i" "@as []"; done
    – meedstrom
    Commented Jul 4 at 13:35
0

Complementing the answer, I am using the dash-to-dock extension and this extension also rebinds Super+0...9.

What worked for me is also changing the

org/gnome/shell/extensions/dash-to-dock/app-hotkey-{0-9}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .