2

As is known, some computer manufacturers include just one antenna in their laptops, but failing to flash the ROM accordingly. So these computers with Realtek network adaptors have the problem that their wifi connections give very low signals since the driver isn't able to detect the antenna correctly.

I had this problem on my HP laptop with Linux Mint 19 (Tessa), with the RTL8723BE driver. Earlier last month I was able to solve the issue by following these instructions. Basically I set the option for manual antenna selection by doing this:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2

and then the wifi signal worked correctly. To make the change permanent, I wrote options rtl8723be ips=0 ant_sel=2 to /etc/modprobe.d/rtl8723be.conf. And everything worked fine.

But yesterday it seems that everything broke while upgrading to the 4.15.0-47-generic linux kernel (from version 4.15.0-20-generic). The wifi signals were low again — under -80 dB, while being less than 5 meters away from the access point.

So I tried repeating the steps above, with no luck.

I tried manually installing rtlwifi_new manually from source, from the extended branch. make; make install exited correctly, showing install SUCCESS. But when I tried doing

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

I got the error modprobe: ERROR: could not insert 'rtl8723be': Required key not available. So I had to uninstall the package.

I also tried the aforementioned process with ant_sel=1, shutting down, waiting rebooting, etc. No luck.


Some info:

Network info, from inxi -Fxz:

Network:
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000 
  bus ID: 02:00.0 
  IF: wlo1 state: up mac: <filter> 

Kernel version (uname -rv):

4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019
1

I get the same problem sequence with my HP 15-ay188nb (wifi module rtl8723be). I go to the store (it was still under warranty) and I receive it back with the 2 antennas operationnals (without explications), so I suspect a bad assembly or defective module. This was before the last kernel update, so probably it is not related to the kernel, just a coincidence ! Mint 19.1, Kernel 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.