I have a local network set up between two servers running ubuntu 18.04 server. They are connected by a 10G network switch (actually 2 bonded connections 10G each). For performance reasons, in /etc/netplan, I have mtu=9000 for the corresponding interface (ethernet or bond). All machines on the subnet have MTU=9000 set. See my previous question and solution: Link Aggregation (Bonding) for bandwidth does not work when Link Aggregation Groups (LAG) set on smart switch

I can ssh, copy files between machines, etc., at high bandwidth (>15 GBit/sec).

One server has an nfs (nfs4, I tried with nfs3 as well) export. I can mount and view some directories of the nfs from other machines on the subnet. Settings are identical to the HowTo: https://help.ubuntu.com/community/NFSv4Howto.

However, commands like "ls" or "cd" or even "df" will randomly hang infinitely on the client.

I tried changing the MTU to default (1500) on the client and host interfaces, while leaving jumbo frames "activated" on the switch. Oddly, this solved all the issues.

I am wondering if NFS(4) is incompatible with jumbo frames, of if anyone has any insight into this. I have found people "optimizing" nfs with different MTU sizes, and people mention hanging "ls" etc., but never in the same context...

  • I am wondering whether normal frames and jumbo frames are being mixed in the same network, and whether switches/virtual environments having being configured/support that. Commented Apr 3, 2019 at 13:28
  • 1
    And also, by experience i know a lot o protocols are "sensible" to MTU changes. NFS is one of them. Have you mounted the nfs at the client side with rsize and wsize as explained here? unix.stackexchange.com/q/346197/34720
    – user34720
    Commented Apr 3, 2019 at 13:30


You must log in to answer this question.

Browse other questions tagged .