0

I am using a powerpc, and after building and flashing the linux kernel on the device I can see the file system. But if I try to create a user or make any changes they get erased and resets to default after I reboot the device. The kernel image location is on network. I am not able to save my changes.

I am using kernel parameter as root=/dev/ram0 I have also used root=/dev/nfs nfsroot=|ip, rootdir| but it is not getting mounted

How can I see the file system of my target on my host linux such that , I can see the target device kernel file system on my host machine and save if even I reboot the device.

update with kernel parameters:

console=ttyS0,9600 root=/dev/nfs rw nfsroot=(ip of the server):/path/Linux ramdisk_size=64000 ip=(client ip):(server ip):(gw):(mask):bommy:eth0:off:(ip:ip:ip)

  • Going by this guide, you have to select NFS client support as built-in during configuration. Did you do that? – Entropy0 Apr 3 at 12:34
  • yes i already did that, but still i cannot see it as mounted when i reboot it. When i type mount i get something like this rootfs on / type rootfs (rw) /dev/root on / type ext2 (rw) proc on /proc type proc (rw) which should not correct – Subramanyam Duvvuri Apr 3 at 13:26
  • Can you update your question with the exact kernel command line parameters when using root=/dev/nfs? One idea to investigate in this case ... ensure the host linux exports the target's root filesystem with no_root_squash (maybe show us the /etc/exports entry for it?) – Murray Jensen Apr 4 at 1:24
  • I updated the kernel parameters. I didnt get this part " ensure the host linux exports the target's root filesystem with no_root_squash". How do i do it? I cannot post the result of /etc/exports as it has some company ip addresses. but it has only one line which is /usr1/path ip/ip (rw,sync) – Subramanyam Duvvuri Apr 4 at 7:34
  • Without no_root_squash, (the user) root will not have write permission in its root file system (this can work if set up correctly, but maybe not in your case) ... the entry you showed does not have no_root_squash - only rw and sync ... try a specific entry in /etc/exports on host linux for /path/Linux with access only for client and no_root_squash option – Murray Jensen Apr 4 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.