1

I have an intel i5 2400 cpu and this Intel DQ67SW desktop motherboard.

The PC had Windows installed, booting to Windows automatically OK. With Linux installed, nothing is booted and I get a message saying "no bootable devices detected" or something like that. Smashing on the boot options key while booting, I am given a menu to manually choose which device to boot from. If I select the drive with Linux installed, it boots normally. There doesn't seem to be anything in the BIOS settings to tell it to boot from this drive. Adjusting the boot order doesn't work.

Intel NUC computers before 2015 seem to have a problem which is very similar to the one I am facing now.

However, my motherboard BIOS makes no mention of Linux. To reduce the amount of variables, I've tried installing the latest version of Ubuntu (18.04.2 LTS). Before rebooting, I tried the commands suggested in the article:

$ sudo mount /dev/sda1 /mnt
$ sudo mkdir /mnt/EFI/BOOT
$ sudo cp /mnt/EFI/ubuntu/* /mnt/EFI/BOOT
$ sudo mv /mnt/EFI/BOOT/grubx64.efi /mnt/EFI/BOOT/bootx64.efi

I ran into problems very fast though. This article seems to be written for an older version of Ubuntu, as my Ubuntu install did not have an EFI folder. I ran a find command for all EFI files that the installer created, and they were all over the place. I tried copying /usr/lib/system/boot/efi/system-bootx64.efi to /EFI/BOOT/bootx64.efi, but that didn't work.

I'm unsure what to do at this point.

Windows 10 Professional was installed in the past. None of the Linux installers indicate that there is a windows partition, and I always delete all the partitions before reinstalling Linux.

I updated the motherboard to the latest BIOS version (0070) yesterday, but that did not solve the problem.

The UEFI boot setting on the motherboard is enabled.

There doesn't seem to be an option for secure booting. Fast booting is disabled.

My motherboard BIOS configuration can be seen here.

1

Turning off UEFI in the BIOS solved my problem!

I reset my BIOS settings to factory defaults in the exit menu, and that changed my bios quite a bit, adding some menu items that were not there previously. Perhaps a bug in the intel BIOS update process? Either way I can't be sure what the actual fix was, resetting my BIOS settings, which magically made more boot options appear, or turning off UEFI, which the BIOS reset also did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.