Sometimes, the mouse scrolling speed changes to a very slow rate, where it takes many clicks (3-8 clicks) or significant wheel rotation to scroll the page one step. This started after upgrading to linux kernel 5.0. It has not happened yet after booting back into kernel 4.20.

When it happens, it's usually upon the wireless mouse 'waking up' after having gone into its power saving mode, but it does not happen every time.

Turning the mouse off and on again with its power switch restores normal behavior.

The mouse is a wireless Logitech M720 used with a Unifying receiver. There is also a wireless keyboard, a Logitech k830, paired with the same receiver.

I know kernel 5.0 introduced new high resolution scrolling support. Is this a bug with that feature? Has anyone else experienced this?

  • seeing exactly the same behaviour in Pop_OS! 19.10 (Ubuntu) on a MX Anywhere 2S
    – Vlax
    Jan 28, 2020 at 14:32

3 Answers 3


One solution is to have solaar running, and make sure that the Wheel Resolution setting for the mouse (M720 in my case) is ON in kernel 5.0, which results in normal scrolling behavior. With solaar set to autostart, I have not had the slow scrolling problem since.

When this setting is OFF it consistently results in the slow scrolling behavior. For whatever reason, without solaar running in kernel 5.0, the mouse sometimes spontaneously switches to that behavior, though without actually changing the setting.

Interestingly, in kernel 4.20 and earlier, Wheel Resolution = OFF resulted in normal scrolling behavior, while ON provided much faster, more sensitive scrolling.


It sounds like this kernel issue here: https://bugzilla.redhat.com/show_bug.cgi?id=1701322.

With my Logitech Performance MX mouse, checking (or un-checking and re-checking) the "Smooth Scrolling" option in Solaar "fixes" the issue, at least until the next time the mouse "sleeps".

  • That bug is exactly the same, including the multiplier = 8 in journalctl, which I've noticed many times.
    – adatum
    May 22, 2019 at 18:23
  • "turn the mouse off and on to fix it" that worked for the mx anywhere 2s on Fedora 30
    – Ray Foss
    Sep 9, 2019 at 14:40
  • live saver! it worked for me too...
    – Vlax
    Jan 28, 2020 at 14:30

A temporary workaround:

solaar config M720 hires-smooth-resolution True

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .