1

I have troubles "deactivating" the Grub boot loader.

Basically I just want to hide it to spare me some time.

Therefore I tried editing the grub file in /etc/default and changed the values according to this page (or any other page referring to that matter).

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true

At the end I also ran sudo grub-update.

Furthermore I tried reinstalling grub (-pc/-common) completely using apt.

I'm only running Ubuntu so either hiding it or instantly choosing the first option (without it showing) are viable. (GRUB_DEFAULT is already set to 0).

Current behavior: Grub is not hidden.

1

Put the following line into /etc/default/grub

GRUB_DISABLE_OS_PROBER=true

From Grub2/Setup in Ubuntu documentation specific entries, item #16.2:

While both methods prevent os-prober from running and placing items in the menu display, using this setting allows the 30_os-prober script, but not the os-prober command, to run. This script enables the GRUB_HIDDEN_TIMEOUT setting and/or the ability to display a hidden menu by pressing the ESC key (depending on other settings). This functionality is lost if the 30_os-prober script is disabled by making it unexecutable.

However it makes any other OS disappear from the list. Memtest and advanced options will be still available.

Another option is to set GRUB_TIMEOUT="1" While it is kind of a hack, it speeds boot up by 9 seconds and allows you to boot other systems.

Also remember to run sudo update-grub to apply any changes you made.

1
  • Thanks for the tip, but sadly it didn't work. (both) – mortom123 Apr 3 '19 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.