I work for buildroot. My purpose work GUI on my buildroot with Gtk3.0 and Gstreamer1.0. I use Olinuxino A13 so I wrote GUI code(Gtk3.0 hello world example) on this with codeblocks. I use Debian wheezy. I want transfer this code from Debian wheezy to buildroot. I tried this:

  1. I transferred /path_to_proectfile/bin/Debug/my_program.my_program created by codeblocks. I wrote ./my_program on terminal and code work. I transferred this file to my buildroot but ./my_program does not work. It returns No such file or directory error.

  2. I thought the problem might be compiling and tried compiled on terminal. I use gcc -o my_program main.c 'pkg-config --cflags --libs gtk+-3.0' again work on Debian wheezy terminal. After I transferred to buildroot but result does not change. I tried different compile kind like cc,arm-linux-gnueabi-gccetc. but every time No such file or directory error.

Finally when I don't use gtk library(Just use printf Hello World), I saw Hello world. When I add gtk library returns No such file or directory error. Have you any suggestion?

  • Welcome to UNIX & Linux StackExchange. I am not much of a programmer, so unfortunately I can't help you with your issue. However, there could be others here who can. If you do not get a response here after some time, I suggest you consider posting on the StackOverflow.com Stack Exchange site as well? That community is dedicated to software professionals who may be better suited to assist you. Good luck! – 0xSheepdog Apr 2 '19 at 15:10

If you want your program to work on a Buildroot system, it has to be compiled with the cross-compiler provided by Buildroot. See slide 264 and following in https://bootlin.com/doc/training/buildroot/buildroot-slides.pdf (i.e the "Application Development" section).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.