2

We recently bought a Lenovo Ideapad 330-15ARR (81D200DDPB) and I tried to install Arch Linux on it. This PC has an AMD 3 2200U CPU and AMD Radeon Vega 3 GPU.

Most of the boot ups end with a black screen. I first see the Lenovo splash logo, then there's the "starting version xxx" message from systemd, and then I would expect to see the display manager (GDM in this case). But, in about 80% of the time, instead I see a black screen. It is probably not "completely off", as I see that it actually is illuminated and it most likely is displaying an all-black image.

Important fact; the very same thing happens with the vanilla Arch Linux installation media (USB pen drive in my case). It ends up with black screen most of the time too.

The system is fully upgraded as of today.

When it actually boots properly everything seems to work fine and I can do whatever I want, but when it ends with black screen, there is nothing I can do. I tried switching virtual TTY with Ctrl + Alt + Fx, but this just doesn't change anything. The only important thing I tried is to disable Wayland for GNOME/GDM, but this did not make any difference.

Any pointers how should I get to the root cause of this problem and solve it?

  • @K7AAY - how can dmesg help if it is only for the current boot? In the failed boot I cannot access dmesg at all. I've browsed through journalctl output for the failed boot, but there is no explicit error in there. I just suddently stops in the middle of boot and doesn't go any further. – Freddie Chopin Apr 2 '19 at 20:43
  • OK, it stops. What was it doing right before it stopped? As to the AMD Graphics Driver, I don't have an answer, because Warning: Arch Linux is officially not supported as per wiki.archlinux.org/index.php/AMDGPU#Loading – K7AAY Apr 2 '19 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.