2

In Linux Mint 18.3 which boots from an HDD, I want to mount an external SSD.

When I run the command sudo fdisk -l, I get all the drives and partitions as well as the SSD and when I run sudo blkid, I get the type and UUID of each of them. I know that gpt and mbr are the partition scheme for storage drives and ext4 or other extension of ext are the file system types in linux . However, the type for ssd is mentioned as gpt in the results from the aforementioned commands.

I tried to mount the SSD by editing the fstab file in /etc/fstab and adding this line ( I set the mount point as /media/ssd-mountpoint ) :

uuid=<the uuid I got from blkid command> /media/ssd-mountpoint gpt defaults 0 2

After using mount -a, however I get the error "the gpt type is unknown".

How can solve this to mount the ssd with gpt type? Should I convert this format?

  • 4
    gpt is a partition type (vs dos ), and not a file system. Can you share the full out put of fdisk -l /dev/nvme0n1 ? IS this a new disk, or have you used it before on other systems. nvme01n1 is the full disk, if it has been partitioned, and formatted there should be a /dev/nvme01n1p1 as well. – Fitz Apr 1 at 19:07
  • On GPT disks isn't the command to use parted and not fdisk? – mdpc Apr 1 at 19:10
  • 2
    recent versions of fdisk do support gpt, but yes parted might be better to use. I'm not sure what version of fdisk comes with mint 18.3 – Fitz Apr 1 at 19:17
  • 1
    You cannot mount a disk that has no filesystem on it: first you'll need to create a filesystem, then you can mount it. For a data disk, it is possible to just use the whole disk for a single filesystem, making partitioning optional. So the order of operations should be: first optionally partitioning and/or LVM, then creating a filesystem (specifying the desired FS type), then mounting it. For a data disk, partitioning is not mandatory but makes it easier to detect that the disk is in use, should the disk be accessed in another system for any reason. – telcoM Apr 2 at 9:29
  • 1
    @ArghavanM.hasani Here are a few for Ubuntu Linux, which should work for Mint Linux as well: InstallingANewHardDrive, How do I add an additional hard drive?, Partitioning, Formatting, and Mounting a Hard Drive in Linux Ubuntu 18.04. – Haxiel Apr 2 at 10:38
3

First let's reach to the the description of the first three fields of fstab format, from man fstab:

The following is a typical example of an fstab entry:

LABEL=t-home2 /home ext4 defaults,auto_da_alloc 0 2

The first field (fs_spec). This field describes the block special device or remote filesystem to be mounted.

The second field (fs_file). This field describes the mount point (target) for the filesystem

The third field (fs_vfstype). This field describes the type of the filesystem. Linux supports many filesystem types: ext4, xfs, btrfs, f2fs, vfat, ntfs, hfsplus, tmpfs, sysfs, proc, iso9660, udf, squashfs, nfs, cifs, and many more. For more details, see mount(8).

The first parameter is device identification, it can be either UUID= or /dev/nvme0n1 (or whatever else device name is reported by blkid or lsblk utilities).

The second parameter is the mount point, i.e. where you want the mounted filesystem to appear in your local filesystem, for example /mnt/mydisk, assuming you have created such a directory and it is entirely empty.

Finally, gpt is not a type of filesystem, and that's what is expected in this field. In the context of fdisk and gdisk utilities, gpt is the partitioning scheme applied to divide the whole of the disk into partitions. This partitioning scheme corresponds to the type of partition table, residing in a (relatively) small block of data, around 1MB, starting at the zero position of the /dev/nvme0 (note, no n1 suffix) device. The actual filesystem is what resides in the n1 partition (just past the partition table), and it will typically have one of the types listed my man fstab

You can use this command sudo fsck -N /dev/nvme0n1 to tell you the filesystem to put there. More specifically this command will tell you which "flavour" of fsck command recognized this filesystem (this way telling you its type, in an roundabout way, e.g. if the filesystem was recognized by fsck.ext4 that means you can put ext4 there)

  • I editted my question and fixed my mistakes. I know that gpt is not the file system type but I should change it so that when I run the blkid or fdisk command again, the type is shown as a filesystem one not gpt. Does fsck command just report the suitable file system type? How can I convert the type to ext4 then? – Arghavan M.hasani Apr 2 at 8:36
0

For the solution to this problem, there are some information in various tutorials. The following steps are prerequisite towards making the new SSD usable:

1. Partition

2. Create a File System and Format

3. Mount

Number of partitions, into which the SSD is divided, is optional. In this problem, it is inteded to divide it into a big single partition. Also, the file system type has been chosen as ext4. You can use either extensions of ext if you are going to use this partition only in Linux. The referrence to the complete (graphically or through the command line) solution with the commands for each step is made here:

Installing a New Storage Drive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.