2

I'm using i3 and imported some keybinds from another user that has the US keyboard. From the i3 forums, the easiest way to do this would be to do:

setxkbmap -layout us,pt .....

This solution seems to work fine with other keymaps (ca,fr, etc) but when it comes to PT, it doesn't work no matter what I do.

I have a little script that is executed when i3 starts. This script is located on .config/i3/config with exec --no-startup-id keybindremap

The script in question is as it follows:

xset r rate 300 50
setxkbmap -model acer_laptop -layout pt -variant ,, -option caps:super
killall xcape 2>/dev/null ; xcape -e 'Super_L=Escape'
xmodmap -e 'keycode 135 = Super_R'

My problem is when I do:

setxkbmap -model acer_laptop -layout us,pt -variant ,, -option caps:super

the keyboard STAYS on the us setting.

  • setxkbmap -model acer_laptop -layout us,pt. If you put us first, this mapping will have precedence over the pt. What about if you use only -layout pt or -layout pt,us ? – user34720 Apr 4 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.