I've just performed a fresh install of Arch Linux on my laptop (ThinkPad A485, though that's probably not relevant here), and installed XFCE4. Everything seems to be working with the exception of one (very peculiar) issue with the terminal emulator: whenever I open a new terminal window, the output of whatever command I enter is (usually) blank until I either highlight it with my cursor or press another key. For example,

[user@thinkpad ~]$ls

looks like (after pressing ENTER):

[user@thinkpad ~]$ls

(a blank line where the output should be). However, when I press ENTER, any other key, or highlight the blank line with my mouse, the blank line changes, making the terminal now look like

[user@thinkpad ~]$ls
Desktop  Documents  Downloads  Music  Pictures  Public  Templates  Videos

which is the (expected) output of ls. This sort of "delay" occurs almost always on the first command I enter in any terminal window, and sometimes at (seemingly) random commands after, particularly with sudo where it will hide the password prompt until the password is entered or some other key is pressed.

A few important things to note:

  • I'm using bash 5.0.2 for the most part, however, I have also encountered the exact same issue on ksh and fish

  • I've tried the following terminal emulators and experienced the above issue with all of them under XFCE: xfce4-terminal, gnome-terminal, lxterminal, tilda, mate-terminal, and terminator. All of these have encountered this issue across bash, ksh, and fish. So far I have not been able to recreate the problem in xterm.

  • The system has been rebooted several times
  • This issue affects SSH sessions as well, blanking out lines of output until highlighted or another key is pressed
  • The issue does not come up under other desktop environments -- I've installed LXDE and MATE, and terminal sessions behave exactly as they should with no blanked out lines.
  • When the issue does come up, running reset or stty sane usually prevents it from happening again within that terminal window. However, adding stty sane to my .bashrc does not seem to resolve the issue, and any new terminal windows still have the same problem

My .bashrc is pretty vanilla, but here it is:

# ~/.bashrc

# If not running interactively, don't do anything
[[ $- != *i* ]] && return
stty sane
alias sudo='sudo -p "Password: "' 
alias ls='ls --color=auto'
PS1='[\u@\h \W]\$ '

(I had added the sudo -p alias and the stty sane line in hopes of fixing it, but neither has had any effect under bash). My kernel is 5.0.5-arch1-1-ARCH .

  • 1
    Thanks for the reply. echo $TERM outputs xterm-256color. As for the color combinations, I've played around with a variety of different ones (dark on light, light on dark, etc.) but I'll see if set -x produces anything meaningful – mk73 Mar 31 '19 at 23:59
  • 1
    set -x doesn't produce anything unusual either (though it is affected by the blank spaces just at much). For example, running ls after set -x produces + ls --color=auto (which makes sense, as that's alias I have for "ls" in my bashrc) – mk73 Apr 1 '19 at 0:08
  • 1
    @StéphaneChazelas In XFCE I'm using xfwm4. I tried installing rxvt, and after several attempts I have not been able tor ecreate the issue there, so maybe using an emulator which is not dependent on VTE is one workaround. – mk73 Apr 1 '19 at 17:12
  • 1
    @egmont here's the output of printenv in LXDE: pastebin.com/StTV6Sq6 and from XFCE: pastebin.com/whxW51Yq I'll summarize the differences in a moment – mk73 Apr 1 '19 at 17:12
  • 1
    xfce seems to have SESSION_MANAGER=local/thinkpad:@/tmp/.ICE-unix/4504,unix/thinkpad:/ , however, LXDE doesn't have any such line when running printenv. But both show the same VTE version – mk73 Apr 1 '19 at 17:16

I have a similar problem with AMD Ryzen 5 3400G. According to this and this, the problem seems to be associated with the integrated graphics card drivers, and a workaround is setting Settings Manager -> Appearance -> Fonts -> Sub-pixel order to something other than "None".

Also seems to be discussed here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.