1

I have installed Kali linux on my Gemini pda. It boot up fine and works without problems.

I tried to run apt-get update and then apt-get upgrade, but the second command fail all the time.

I get the the following packages have unmet dependencies for vim, vim-gtk and vim-tiny. I tried to run apt --fix-broken install but this won't work, since I get the prompt if I want to fix vim and I get again the same unmet packages error,

Tried as last resort to remove vim, but this won't work either, I still get the error about dependencies. Tried to apt remove all the vim packages without any luck.

also tried to run apt-get clean && apt-get purge but even this didn't fix the problem.

Not sure why is not possible to update at this point. This is what I get when I run apt-get upgrade

    The following packages have unmet dependencies:
      vim: Depends: vim-runtime(= 2:8.1.0875-2) but 2:8.1.0875-1 is installed
      vim-gtk : Depends: vim-runtime (= 2:8.1.0875-2) but 2:8.1.0875-1 is installed
      vim-tiny:  Depends: vim-common (= 2:8.1.0875-1) but 2:8.1.0875-2 is installed
    E: Unmet dependencies. Try `apt --fix-broken install` with no packages (or specify a solution).

EDIT: Seems that no matter what I try to install, or remove, that message continue to pop up. I did look into forcefully remove VIM, but it seems it is part of the Kali complete packaging set, so removing that may cause issues to other apps that rely on that package. Tried to force install, force uninstall, nothing did work.

I may end up either going back to Debian, or re-installing again the distribution on the Gemini, and avoid to install VIM to start with (followed the instructions on the install page of the Gemini kali distro), by not installing all the other packages (the distro come with the top-10 packages I believe; not sure since this is the first time I use Kali, my usual distribution was Debian in the past).

  • Nice, first downvote from the guy that does not know how to solve the issue. Thanks! – rataplan Mar 31 at 2:29
2

Looks like the package repository you're getting Kali updates from did its last mirroring cycle just as the person responsible for Kali's vim packages was in the middle of updating them.

As a result, you now have vim-runtime version 2:8.1.0875-1, but vim-common version 2:8.1.0875-2. Also it looks like your vimpackage has also been upgraded to 2:8.1.0875-2.

You might try doing this:

apt-get --allow-downgrades install vim-gtk=2:8.1.0875-1 vim-common=2:8.1.0875-1 vim=2:8.1.0875-1

to force all the vim packages to version 2:8.1.0875-1. Then wait a while (maybe a few hours, up to a day or so) to allow your package repository to complete another mirroring cycle, and then retry the update.

If that does not solve it, there might be a problem in the package repository mirror you're using. Check /etc/apt/sources.list and/or the files in /etc/apt/sources.list.d/ directory for the hostname of the apt mirror you're using, and switch to another Kali mirror repository and/or contact the repository mirror server administrator and report the problem.

The list of official mirrors of the Kali repository server can be found here.

  • Thanks a lot for your reply! Tried it and I get an error because there is no 2:8.1.0875-1 for the packages. I guess I need to contact the folks at Kali that did the distro for the Gemini, and ask them what is the repo location for the latest VIM packages. Thanks a lot for pointing me to the right direction One word of caution for everyone at this point is to NOT INSTALL kali-linux-full on the gemini – rataplan Mar 31 at 20:21
1

Thanks to telcoM for giving me a trail to follow; I was able to fix the issue.

I did remove the /etc/apt/sources.list file, which had some entry that were not for the gemini distribution; then I ran dpkg -r vim-tiny to remove the tiny package that was triggering the mismatch. Last step was to run

sudo apt-get --purge autoremove vim
sudo apt-get --purge autoremove vim-runtime
sudo apt-get --purge autoremove vim-gtk

Then I ran sudo apt --fix-broken install to set up VIM with the correct packages versions, and finally do a sudo apt-get update

This did refresh my repository, so I could start from a fresh start.

When I ran sudo apt-get upgrade, everything works fine now; the version mismatch did disappear and now I can update and install new packages.

  • I followed this answer. It upgraded alright, but when I restarted the system, it is stuck at planet boot screen. Is there anything I could do apart from reflashing? Please note that I am installing kali alone, without Ubuntu... – mlwn May 15 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.