1

I am trying to install xpra on CentOS 6.9.

Upon yum install xpra, I get:

Error: Package: xpra-1.0.12-2.r19800.el6_9.x86_64 (winswitch)
           Requires: libx264.so.148()(64bit)
           Available: x264-xpra-20170704-1.el6_9.x86_64 (winswitch)
               libx264.so.148()(64bit)
           Installing: x264-xpra-20190109-0.el6_9.x86_64 (winswitch)
               Not found

I downloaded the package x264-xpra-20190109-0.el6_9.x86_64 manually and installed it using it yum localinstall

This results in the ollowing error on yum install xpra:

Error: Package: xpra-1.0.12-2.r19800.el6_9.x86_64 (winswitch)
           Requires: libx264.so.148()(64bit)
           Available: x264-xpra-20170704-1.el6_9.x86_64 (winswitch)
               libx264.so.148()(64bit)
           Installed: x264-xpra-20190109-0.el6_9.x86_64 (@/x264-xpra-20190109-0.el6_9.x86_64)
               Not found

I noticed that /usr/lib64/xpra only has libx264.so.155, therefore I tried locating a package online that has libx264.so.148.

That is x264-xpra-20160704-1.sdl6.x86_64.rpm. I installed it using yum localinstall again and verified that libx264.so.148 was indeed present in /usr/lib64/xpra.

However, now upon trying to reinstall xpra, I get:

Error: Package: xpra-1.0.12-2.r19800.el6_9.x86_64 (winswitch)
           Requires: libx264.so.148()(64bit)
           Removing: x264-xpra-20160704-1.sdl6.x86_64 (@/x264-xpra-20160704-1.sdl6.x86_64)
               libx264.so.148()(64bit)
           Updated By: x264-xpra-20190109-0.el6_9.x86_64 (winswitch)
               Not found
           Available: x264-xpra-20170704-1.el6_9.x86_64 (winswitch)
               libx264.so.148()(64bit)

I'm quite lost, how can I proceed?

  • I looked at the RPM files, and it seems that the 'libx264.so.148' file is provided by the 2017 version of the package (x264-xpra-20170704-1.el6_9.x86_64). That package is also in the same repo. Perhaps yum found the new version of package, but found that it did not resolve the dependency, and hence failed? In any case, try installing this package locally and then see if the main installation works. You'll need to remove the two packages you've already installed. – Haxiel Mar 29 at 13:45
  • Tried doing what you said, but got: Error: Package: xpra-1.0.12-2.r19800.el6_9.x86_64 (winswitch) Requires: libx264.so.148()(64bit) Removing: x264-xpra-20170704-1.el6_9.x86_64 (@/x264-xpra-20170704-1.el6_9.x86_64) libx264.so.148()(64bit) Updated By: x264-xpra-20190109-0.el6_9.x86_64 (winswitch) Not found – user129186 Mar 29 at 13:49
  • Thanks for the update. I think my assumption still holds here. '20190109' is the latest package in the repo, but it does not satisfy the dependency. That seems like a packaging error. If the number of dependencies isn't large, perhaps you can get them manually with yumdownloader, disconnect the xpra repo and then try to install. If yum is not able to the find the 20190109 package, it should proceed with the installation as expected. – Haxiel Mar 29 at 13:59
0

To solve the dependencies issue ,xpra can be installed on centos from the official repository winswitch:

as root:

rpm --import https://winswitch.org/gpg.asc
curl -o /etc/yum.repos.d/winswitch.repo -O https://winswitch.org/downloads/CentOS/winswitch.repo
yum install xpra

Xpra download page:

For step by step instructions on setting up these repositories, follow the ​repository installation instructions for winswitch and install the "xpra" package instead of "winswitch" (or both).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.