0

I'm used to keyboard shortcuts like ^a (go to the beginning of the line) in a terminal session.

When I'm running GNU "screen" (so I can resume an ssh session after packing up my laptop), a bunch of those, such as ^a, don't seem to exist. Or conflict with screen's.

How can I get them, or something like that, back when running screen?

2

man screen:

   ├─────────────────┼─────────────────┼─────────────────────┤
   │C-a a            │ (meta)          │ Send  the   command │
   │                 │                 │ character  (C-a) to │
   │                 │                 │ window. See  escape │
   │                 │                 │ command.            │
   ├─────────────────┼─────────────────┼─────────────────────┤

or:

   -e xy
        specifies the command character to be x and the character generat‐
        ing a literal command character to y (when typed after the command
        character).   The default is "C-a" and `a', which can be specified
        as "-e^Aa".  When creating a screen session, this option sets  the
        default  command character. In a multiuser session all users added
        will start off with this command character. But when attaching  to
        an  already  running session, this option changes only the command
        character of the attaching user.  This option is equivalent to ei‐
        ther the commands "defescape" or "escape" respectively.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.