2

I am trying to auto install debian buster with ipxe, it seems that the boot parameters don't work in the ipxe menu. I always get the language section. So the preseed isn't loaded. Here is the relevant entry in the ipxe menu:

:d10-dc-node
set base-url https://d-i.debian.org/daily-images/amd64/daily/netboot/debian-installer/amd64
kernel ${base-url}/linux
initrd ${base-url}/initrd.gz
imgargs linux vga=normal root=/dev/ram rw preseed/url=tftp://my.ipxe.server/preseed/debian_buster_node.seed netcfg/choose_interface=eno1 debian-installer/framebuffer=false debian-installer/locale=en_US kbd-chooser/method=us auto-install/enable=true debconf/frontend=noninteractive debconf/priority=critical console-setup/ask_detect=false keyboard-configuration/modelcode=pc105 keyboard-configuration/layoutcode=us keyboard-configuration/variant=USA hostname=ubuntu ---

and here is the preseed part:

### Keyboard
d-i                 console-setup/ask_detect                        boolean                 false
d-i                 keyboard-configuration/layout                   select                  USA
d-i                 keyboard-configuration/variant                  select                  USA
d-i                 keyboard-configuration/modelcode                string                  pc105
d-i                 keyboard-configuration/xkb-keymap               select                  en
d-i                 keyboard-configuration/layout                   string                  English

### Locales
d-i                 debian-installer/country                        string                  DE
d-i                 debian-installer/language                       string                  en
d-i                 debian-installer/locale                         string                  en_US.UTF-8
d-i                 localechooser/supported-locales                 multiselect             en_US.UTF-8, de_DE.UTF-8

When I try to set the base-url to http://ftp.de.debian.org/debian/dists/buster/main/installer-amd64/current/images/netboot/debian-installer/amd64 it works fine until loading the modules, then I get the following error: "No kernel modules were found", which I guess because of the different Kernel versions.

1
  • I acheived to pass the kernel parameters after changing them to imgargs linux auto preseed/url=tftp://my.ipxe.server/preseed/debian_buster_node.seed netcfg/choose_interface=eno1 auto-install/enable=true fb=false debconf/frontend=noninteractive debian-installer=en_US.UTF-8 auto locale=en_US.UTF-8 console-setup/ask_detect=false kbd-chooser/method=us keyboard-configuration/xkb-keymap=us keyboard-configuration/modelcode=pc105 keyboard-configuration/layout=USA keyboard-configuration/variant=USA BOOT_DEBUG=2 -- the only problem I still have is that the preseed is not being loaded!? – Max Mar 29 '19 at 15:13
0

I finally could install debian buster fully unattended by using the following Kernel arguments:

:d10-dc-node
set base-url https://d-i.debian.org/daily-images/amd64/daily/netboot/debian- 
installer/amd64
kernel ${base-url}/linux
initrd ${base-url}/initrd.gz
initrd tftp://my.ipxe.server/preseed/debian_buster_node.seed /tmp/debian_buster_node.seed
imgargs linux auto vga=normal root=/dev/ram rw file=/tmp/debian_buster_node.seed interface=eno1 fb=false debian-installer=en_US.UTF-8 locale=en_US.UTF-8 kbd-chooser/method=us auto-install/enable=true debconf/frontend=noninteractive priority=critical console-setup/ask_detect=false keyboard-configuration/xkb-keymap=us keyboard-configuration/modelcode=pc105 keyboard-configuration/layoutcode=us keyboard-configuration/variant=USA ---
boot

Network configuration and hostname will be set with DHCP.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.