1

I was trying to install redis from source in Ubuntu 14.04 and Ubuntu 16.04. I did followed everything exactly from this tutorial.

Only difference was that my logfile path was /redis/logs/redis-server.log instead of /var/log/redis.log in redis.conf file.

It worked perfectly in Ubuntu 16.04 but in Ubuntu 14.04, while enabling redis.service through command sudo systemctl enable redis, systemd started searching for init file and and tried to enable through update-rc.d rather than usual method i.e. creating a soft link of /etc/systemd/system/redis.service file in /etc/systemd/system/multi-user.target.wants directory. Of course, it couldn't because there was no init file for redis.

Later, I changed the path of logfile to /var/log/redis/redis-server.log in Ubuntu 14 only and it fixed the problem. My question is why this happened? Is there some dependency of systemd on logfile location? What changed in Ubuntu 16?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.