I'm currently(or was anyway) running a dual-booted system with Windows10 and Arch Linux on it. They were each on their own separate SSD and everything worked fine for the most part (had to switch between them using bios boot menu because grub wouldn't recognize windows no matter what I tried but that's another issue). A couple of hours ago I was in working in Arch and there was a power outage. When I rebooted my system the motherboard was freaking out and I had to reset the CMOS to get it to work. However, I can now only boot into windows. If I try to boot to the drive with arch on it, it tells me to insert a bootable image.

From what I've tried so far, I know the partitions are still labeled and sized correctly with the correct file systems (EFI boot, main arch partition, and swap). I suspect that my grub is broken but I'm not sure how to go about fixing it. I have no experience with repair a Linux system since in the past I've just wiped the drive and started over.

I've tried supergrubdisk2 but I just got failures for anything grub.

closed as too broad by RalfFriedl, user34720, jimmij, DarkHeart, roaima Mar 28 at 22:55

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I guess this is not the correct platform for such questions. Because to solve your issue we need to ask questions that you need to answer. It sounds more like a bulletin board thread... First question: can you start a linux from usb stick, open a console and add the output of fdisk -l? – iRaS Mar 28 at 6:14
  • 1. Check your BIOS / EFI settings. 2. Please edit your question to clarify what you mean by "it" in "it tells me to insert a bootable image" - is that grub, or Windows, or your PC boot firmware? 2. Why do you suspect grub is broken - what evidence (if any) do you have for this? – roaima Mar 28 at 22:54