1

I have an Android TV box running Armbian 5.41 (Ubuntu 16.04.5). Since I changed from kodi-standalone to MATE, I've found a network issue.

The box is connected via Ethernet, and MATE shows two interfaces: eth0 and ifupdown(eth0). I want to use eth0, because i can not set an static IP on ifupdown, because it's ready-only. Every time I restart MATE, it automatically connects to ifupdown, resulting in not having any network.

I need the static IP, because I've got Pi-Hole running on it as well, with an enabled DHCP server. The static IP of eth0 has been set in network manager. How can i remove this interface or at least setting the normal eth0 as default?

/etc/network/interfaces

# Wired adapter #1
allow-hotplug eth0
no-auto-down eth0
iface eth0 inet dhcp
#address 192.168.0.17
#netmask 255.255.255.0
#gateway 192.168.0.1
#dns-nameservers 8.8.8.8 8.8.4.4
#       hwaddress ether # if you want to set MAC manually
#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838


# Wireless adapter #1
# Armbian ships with network-manager installed by default. To save you time
# and hassles consider using 'sudo nmtui' instead of configuring Wi-Fi settings
# manually. The below lines are only meant as an example how configuration could
# be done in an anachronistic way:
#
#allow-hotplug wlan0
#iface wlan0 inet dhcp
#address 192.168.0.100
#netmask 255.255.255.0
#gateway 192.168.0.1
#dns-nameservers 8.8.8.8 8.8.4.4
#   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
# Disable power saving on compatible chipsets (prevents SSH/connection dropouts over WiFi)
#wireless-mode Managed
#wireless-power off

# Local loopback
auto lo
iface lo inet loopback
0

From /etc/network/interfaces:

# Armbian ships with network-manager installed by default. To save you time
# and hassles consider using 'sudo nmtui' instead of configuring Wi-Fi settings
# manually.

Edit the /etc/NetworkManager/NetworkManager.conf then change the following:

[ifupdown]
managed=true

to

[ifupdown]
managed=false

The Network-Manager will not manage the network interfaces configured under /etc/network/interfaces then run:

sudo systemctl restart network-manager

Use the command sudo nmtui to configure a static IP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.