0

I am trying to install elementaryOS (Juno)'s terminal emulator on Mint 19 Tessa. I checked the instruction at the git hub site https://github.com/elementary/terminal, and I installed all dependencies by using sudo apt install.

After I ran the instructed command meson build --prefix=/usr, I saw the error output as following:

Native dependency granite found: NO found '0.5' but need: '>=5.2.0' meson.build:25:0: ERROR: Invalid version of dependency, need 'granite' ['>=5.2.0'] found '0.5'.

I found the version of this library for Ubuntu is different (though Ver 0.5 is the latest for Ubuntu), but Debian's one is satisfiable. So, I went to Debian package site and downloaded a Debian package libgranite-dev (5.2.3-1), but it wouldn't be installed because the GDebi installer said the dependency was not satisfiable.

How could I cope with this situation to run meson successfully?

0

The package is called pantheon-terminal, available from the elementary repositories, you can enable the repository to build the dependencies libgranite5, then disable it.

sudo add-apt-repository ppa:elementary-os/stable
sudo apt build-dep pantheon-terminal
sudo add-apt-repository --remove ppa:elementary-os/stable
  • 1
    Thanks a lot! I finally installed the pantheon-terminal on Mint!!! By the way, I found the second command line should be sudo apt-get build-dep pantheon-terminal :) – buck_banzai Mar 27 at 17:46
  • I cannot vote up your answer because I still haven't had over 15 reps yet. I will come back and vote your answer after I get more than 15 reps :) – buck_banzai Mar 27 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.