I am working on OpenGL shaders, and I need uint64_t types, etc... However, when I do glxinfo, this extension is not in the list.

I am using Mesa 18.0.5, and this page tells that the extension is supported for radeonsi drivers from 17.1.0.

My GPU is a AMD Radeon HD 8730M. I am using the radeon driver, but switching to amdgpu is not helping.

Question: how can I achieve to use uint64 in my shaders? By switching to another driver? By updating Mesa? Or is my GPU too old?

The shader I try to compile:

#version 450
#extension GL_ARB_gpu_shader5 : enable
#extension GL_ARB_gpu_shader_int64 : enable

void main()
  uint64_t foo = 0ul;

I got:

0:3(12): warning: extension `GL_ARB_gpu_shader_int64' unsupported in fragment shader
0:7(11): error: syntax error, unexpected NEW_IDENTIFIER, expecting ',' or ';'

glxinfo output:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
    GL_3DFX_texture_compression_FXT1, GL_AMD_conservative_depth,
  • I realized that the OpenGL vendor detected by glxinfo is Intel. Is this a sign that mesa is not detecting my AMD GPU ?
    – Hugal31
    Mar 27, 2019 at 11:18

1 Answer 1


Got it.

Mesa was indeed using my integrated graphic chipset. By launching all the commands with the environment variable DRI_PRIME=1, I was able to directly use my GPU, thus enabling the asked extensions.

Howerver, I am not sure if setting this environment variable each time or globally is a good solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.