2

Every time I suspend, when I start up again I can't scroll with two fingers but I have to use three. Does anyone know how to fix this? It works after restart.

My system is a Thinkpad x240 running openSUSE + OpenBox and here's what I get when I run libinput list-devices for the trackpad after suspend and wake up.

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event17
Group:            8
Seat:             seat0, default
Size:             109x96mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a
4

Please read bug report Two-finger scrolling no longer works after resuming from suspend.

Possible fix: Add psmouse.synaptics_intertouch=0 to GRUB_CMDLINE_LINUX_DEFAULT in your /etc/default/grub.

Example:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0"

Then run sudo update-grub and reboot.

  • update-grub isn't a command on openSUSE, but the rest of the answer is correct and helped me fix this, thank you so much! Can you please elaborate on what exactly that does? – vityavv Mar 26 at 21:53
  • 1
    Default on 4.12 kernels (and above?) is communication via RMI4 over SMBus and psmouse.synaptics_intertouch=0 reverts it back to the old style PS/2 behaviour. See comment 42 of the bug report or bugzilla.kernel.org/show_bug.cgi?id=196719. I never noticed this bug on my X250 and T440s as I only use the trackpoint (touchpad disabled in bios) :) – Freddy Mar 26 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.