0

Everything was working fine up until today, I've been fiddling for hours trying to configure ethernet on my arch install with no luck. I run a dual boot system with windows and networking seems to be working fine there.

No matter what I tried every time I tried to ping an address I just got "network unreachable"

I tried booting from a live CD made using the same ISO that I used to make my install in the first place. That doesn't seem to want to connect either (although it worked fine when I used it to make my installation)

Following through the arch wiki I get the following outputs.

lspci -v

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
...
Kernel driver in use: r8169
Kernel modules: r8169

dmesg | grep r8169

[    4.489078] libphy: r8169: probed
[    4.489584] r8169 0000:04:00.0 eth0: RTL8168evl/8111evl, 50:e5:49:44:08:b9, XID 2c900800, IRQ 34
[    4.489586] r8169 0000:04:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    4.493645] r8169 0000:04:00.0 enp4s0: renamed from eth0
[    5.360274] RTL8211E Gigabit Ethernet r8169-400:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-400:00, irq=IGNORE)

From what I can gather this means the kernel driver has been loaded

ip link show dev enp4s0

2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000 
link/ether 50:e5:49:44:08:b9 brd ff:ff:ff:ff:ff:ff

Interface seems to be up but when I run dhcpcd I get an error

sudo dhcpcd enp4s0

enp4s0: waiting for carrier
timed out
dhcpcd exited

I also tried using the example ethernet-dhcp and ethernet-static configs with netctl (changing eth0 to enp4s0 for each config) then enabling and starting them with "netctl enable ethernet-xxx" and "netctl start ethernet-xxxx". That didn't return any errors but I still get "network unreachable".

1

Interface is down and has no carrier. check cabling (NO-CARRIER and state DOWN show this).

what does ifconfig enp4s0 up say?

  • Networking is fine on my windows partition and I've already tried changing the cable (the onboard lan is also my only network device). And I did set the interface to up using "sudo ip link set enp4s0 up" without any error. – J.Clarke Mar 26 at 9:03
  • 1
    From what I can tell you, the r8169 driver will not work, but the r8168 will do. I had this problem also some time ago and had to compile a driver by myself (trying to upgrade your kernel may work also. medium.com/@lgobinath/… is a reference there – stoney Mar 26 at 9:21
  • Thanks for the help, I'll try compiling the r8168 driver manually though I don't think it's a kernel issue somehow since all arch live CD's I've tried have all loaded the same driver and refused to work including the one that worked when I first installed Arch – J.Clarke Mar 26 at 9:24
0

It turned out to be an issue with something in the bios that a recent failed overclock must have reverted.

I'm not exactly sure what the BIOS setting that was causing the issue was as I just reverted back to my preset but someone from this thread suggested to check the PXE setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.