0

I have a machine where i've installed an Ubuntu-studio distro. There i've tried to install the Xen kernel, the XAPI toolstack, and the OpenXenManager; by then i used to have the following results.

 $ egrep '(vmx|svm)' /proc/cpuinfo


6c rdrand lahf_lm cmp_legacy **svm** extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate sme ssbd sev ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca

Where we see that the SVM flag is present at the cpu instructions set. By now, after changing to Debian, because of these and other issues, i no longer see the SVM instructions at /proc/cpuinfo

root@debian /# uname -a
Linux debian 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 GNU/Linux

root@debian /proc# cat cpuinfo 

flags       : fpu de tsc msr pae mce cx8 apic mca cmov pat clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid pni pclmulqdq ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand hypervisor lahf_lm cmp_legacy abm sse4a misalignsse 3dnowprefetch bpext cpb ssbd ibpb vmmcall fsgsbase bmi1 avx2 bmi2 rdseed adx clflushopt sha_ni xsaveopt xsavec xgetbv1 clzero arat

Probably i've made some mistakes while installing the Xen kernel and i believe that my grub does not load these instructions when i boot to my Debian with Xen hypervisor.

Other virtualization services also don't work. KVM and Virtual Box.

No hardware where changed when i've moved from Ubuntu to Debian.

My motherboard has both the SVM and the IOMMU options enabled, and my grub boots to a Debian with a Xen Hypervisor kernel.

Can i recompile my kernel or change my grub to activate this instructions? I say that because i see some SVM stuff installed:

root@debian /# find . -name "*svm*"
find: ‘./run/user/1001/gvfs’: Permissão negada
./usr/src/linux-headers-4.19.0-4-common/arch/x86/include/uapi/asm/svm.h
./usr/src/linux-headers-4.19.0-4-common/arch/x86/include/asm/svm.h
./usr/src/linux-headers-4.19.0-4-common/include/linux/intel-svm.h
./usr/src/virtualbox-6.0.4/include/VBox/vmm/hm_svm.h
./usr/src/linux-headers-4.19.0-4-amd64/include/config/intel/iommu/svm.h
./usr/local/lib/python2.7/dist-packages/nltk/classify/svm.pyc
./usr/local/lib/python2.7/dist-packages/nltk/classify/svm.py
./usr/include/x86_64-linux-gnu/asm/svm.h

My grub:

root@debian /e/grub.d# grub-install --version
grub-install (GRUB) 2.02+dfsg1-13
  • What happens if you boot Debian without Xen? Whe- you’re in Xen, have you tried creating a DomU? – Stephen Kitt Mar 26 at 5:33
  • @StephenKitt it worked for kvm, thanks, but not for xen and virtual box. Probably i've made some mistakes while installing everything. Any tips on grub and other stuff? – Joao Henrique da Silva Mar 26 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.