0

I've enabled Wake-On-Lan on my debian machine with this tutorial. I didn't have the option to try it out or reboot, and went to sleep. The next day, a power surge happened, and rebooted my computer, for the first time in 15 days.

After that, I didn't have any connection on my computer.

I started to troubleshoot :

  • Rebooted the computer.
  • Rebooted the router.
  • Changed the Ethernet cable.
  • Tried to connected via Wi-Fi with a USB key ( Edimax EW-7811Un )
  • Tried to connect via connection sharing from my Android Phone.
  • Connected the same cable and router to another computer running Ubuntu 18.04, and it worked with no issues. So the issue must be coming from my computer.

That didn't change anything. I looked up the Arch Linux wiki ( props btw, it's really nice. ) and suggested to check my Network Manager config.

I linked the output of /var/log/messages, and diverse config files here :

https://0bin.net/paste/Jcp8j30r6NXBS95K#rPQVHP5oFqdWLyO51F-keBGlRwtSSn7wDD2bh4Tv9U7

And more ...

I set the nameserver of the /etc/resolv.conf to nameserver 8.8.8.8 for testing, but it didn't change anything. I also tried with FDN's DNS

When I remove the comments of the /etc/network/interfaces file, and setup the connection by hand, it doesn't change anything, I'm still unable to connect to anything.

I also tried connecting to a IPv6 directly, as well as an IPv4 address.

I also tried to boot on a Ubuntu 18.10 live usb, which worked, but didn't yield anything. I also tried to boot on a Debian 9 live USB in rescue mode, which worked, but didn't yield anything.

PINGing localhost works, but not LAN computers or others.

I also tried to install the r8168-dkms-8.043.02-1_all.deb package from the Debian repo with dpkg and a USB key, and rebooted. Many times. Sadly.

I've also followed the advice found on the Arch Linux forum about Realtek no link / WOL problem. And tried to activate and deactivate several times the Intel Virtualization Technology. I even updated the BIOS to it's last version ( dated 2014 ).

  • It feels like this is missing a critical number of details.  Can you ping your router? If not, stuff like changing nameservers has no chance of having any effect. – G-Man Mar 26 at 1:04
  • No, I cannot ping my router. But on the other hand, my router can see my computer and has affected an IP to it. It shows the good MAC address, and my computer is reachable from the router. – N07070 Mar 26 at 10:30
  • Wait, what? The router can ping the computer, although the computer can’t ping the router? You say “my computer is reachable from the router”; do you mean something other than ping? Through what media is your PC reachable? (Ethernet? Wi-Fi?) You say “my router … has affected an IP to [my computer]”; do you mean that it has assigned an IP address to the computer? What do you mean by “didn't yield anything”? You have confirmed my hunch that you’re not telling us everything you know, which makes it impossible for anybody to answer your question. Please edit it to include all relevant details. – G-Man Mar 26 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.