1

I am using debian 9 with xmonad, and one time after rebooting -- no sound.

When I run speaker-test && pavucontrol, I see that the sound is output to the built-in speakers, but I can't hear it.

What puzzles me even more is this behaviour: when I plug in my headphones, PuleAudio recognizes it and streams to them (no sound in those either), and after some time, when I unplug them the sound comes back for a few seconds (from the speakers), and fades into nothingness.

edit having tried MATE and getting the same result, I'm pretty sure it has nothing to do with my xmonad config

  • 1
    xmonad is just a WM, right? That probably isn't relevant. Can you first check your config in pavucontrol? This isn't optimal, but you could post a screenshot. If anyone knows how to get the config given in pavucontrol as text, preferably via a command, please let me know. – Faheem Mitha Mar 25 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.