0

I am trying to write an ansible role for redis stand-alone server installation. I downloaded the tarball from redis repo, extracted it and ran make commands to install it.

Then I made changes in configuration file, created directories and service file as mentioned here

In the end when I try to enable the service in Ubuntu 14.04, it gives an error:

Synchronizing state for redis with sysvinit using update-rc.d...

Executing /usr/sbin/update-rc.d redis enable

update-rc.d: /etc/init.d/redis: file does not exist

Works fine in ubuntu 16.04 but not in 14.04

I know that, Command systemctl enable servicename creates a soft link of service file in /etc/systemd/system/multi-user.target.wants in ubuntu 16.04. How does it happen in Ubuntu 14.04?

  • 2
    Ubuntu 14.04 uses upstart instead of systemd. Also, 14.04 is EOL in one month. – jordanm Mar 25 at 7:02
  • I would recommend the apt - method: 'apt-get install redis-server' , then 'Service redis-server start' .. This should do the Job. – gerhard d. Mar 25 at 7:42
  • Thank you for you inputs. I needed a working init file in /etc/init.d/ directory. This is how I did it: 1. installed server through install_server.sh script in utils directory in source code 2. got sample init file from it. 3. then used update-rc.d <service> enable command to enable service. – adeel109 Mar 26 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.