0

I have following lines in rsnapshot.conf

snapshot_root   /mnt/T4Backup2T/Incremental-Backup
rsync_long_args --numeric-ids
exclude_file    /home/CD/CLPB/backup-files/rsnapshot/saraswathi.exclude
backup  /   localhost/fedora/   +rsync_long_args=--exclude /home --exclude /mnt --relative --delete --delete-excluded /

it is wrongly producing following lines (--filter option is not specified but still coming up)

/usr/bin/rsync -a --numeric-ids \
    --exclude-from=/home/CD/CLPB/backup-files/rsnapshot/saraswathi.exclude \
    --exclude /home --exclude /mnt --relative --delete --delete-excluded / \
    --filter=-/_/mnt/T4Backup2T/Incremental-Backup / \
    /mnt/T4Backup2T/Incremental-Backup/weekly.0/localhost/fedora/

There is no filter option in rsnapshot.conf but still it is getting produced, what could be misconfiguration?

1

This happens to avoid snapshot_root getting sync again. As explained in the rsnapshot-program.pl

If this backup point contains the snapshot root, add an exclude to avoid backing up the snapshot root recursively. The exclude is anchored (by virtue of the leading slash of $config_vars{'snapshot_root'}) and applies to absolute paths (the "/" modifier), so it should match the snapshot root and nothing else regardless of --relative.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.