61

my raspberry pi 3 model B, running Arch, has an issue with bluetooth. First of all:

  • Bluetooth has worked flawlessly previously
  • pi-bluetooth from the AUR is up to date
  • bluez and bluez-utils are up to date
  • The system is up to date as well (just ran pacman -Syu)

Still, when I try to use the bluetooth interface, it doesn't work.

bluetoothctl (as root), when I run "scan on", tells me

Failed to start discovery: org.bluez.Error.NotReady

wminput can't find the bluetooth interface:

No Bluetooth interface found
unable to connect

"systemctl status bluetooth" has the following output:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2019-03-23 21:32:47 CET; 9min ago
     Docs: man:bluetoothd(8)
 Main PID: 2005 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 1404)
   CGroup: /system.slice/bluetooth.service
           └─2005 /usr/lib/bluetooth/bluetoothd

Mar 23 21:32:47 media.lan systemd[1]: Starting Bluetooth service...
Mar 23 21:32:47 media.lan bluetoothd[2005]: Bluetooth daemon 5.50
Mar 23 21:32:47 media.lan systemd[1]: Started Bluetooth service.
Mar 23 21:32:47 media.lan bluetoothd[2005]: Starting SDP server
Mar 23 21:32:47 media.lan bluetoothd[2005]: Bluetooth management interface 1.14 initialized

I am at my wits end here, everything seems to be fine, yet nothing works. What is going on here?

3 Answers 3

73

I got the same problem. It turned that the @turf answer didn't work for me.

After I checked rfkill:

$ rfkill list
0: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

I ran the command:

rfkill unblock all

And the Bluetooth worked again.

3
  • Thanks a ton @Rafael, does anyone know how this kind of thing can happen? I don't think I did anything different except maybe a system update on Arch Linux
    – seveibar
    Jan 24, 2021 at 16:42
  • Amazing! Thanks!
    – Miller
    Oct 9, 2021 at 23:08
  • In my case, rfkill output all no's, but bluetoothctl indicated that the power was off
    – darw
    Nov 14, 2021 at 9:26
70

Okay, wow, turns out all I had to do was run

bluetoothctl power on
5

In my case the solution was:

bluetoothctl power on

followed by

rfkill unblock all

hci0 was soft blocked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .