2

I have three sinks, which are 3 different soundcards 0 is USB speaker 1 is integrated 2 is hdmi

With those commands

pacmd list-sinks
pacmd set-default-sink 0
pacmd set-default-source 0
pacmd set-sink-volume 0 35000

I can select the sink n°0 but no sound arrive because the card number 1 is still active(pulseaudio list it as suspended). The question is: which command to turn off the card number 1?

2
  • How did you determine that "no sound arrives because the card number 1 is still active"? Or "pulseaudio lists it as suspended"? There are at least three commands being described here, why not tell us what they are and show the output? Mar 24, 2019 at 6:29
  • The card is still active because the command pactl list short sinks show it as suspended.If (from a gui program) I disable it the usb card became the default and I can hear sound.
    – elbarna
    Mar 24, 2019 at 22:09

1 Answer 1

2

First get the correct card index

pacmd list-cards

Assuming the index is 1 you can turn it off like this:

pacmd set-card-profile 1 off

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .