1

I am trying to hide the GRUB menu on Linux Mint 19 Cinnamon.

I edited the grub file using and entering my admin password twice

gedit admin:///etc/default/grub

Then I edited my grub file to look like this:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

After the changes, I updated GRUB with

sudo update-grub

When I restart the PC, I still get the GRUB menu with a 30 second timer. Did I miss some entries or are there also other files I need to edit?

  • 1
    try to remove GRUB_TIMEOUT_STYLE GRUB_HIDDEN_TIMEOUT and GRUB_HIDDEN_TIMEOUT_QUIET and don't forget info grub. – ctac_ Mar 23 at 13:04
  • Thanks! Iĺl try that. What exactly do you mean by info grub? Is that a terminal command to look at the settings? (Sorry, absolute noob here) – Ju Ko Mar 23 at 14:13
  • I suppose ctac_'s reference to "info grub" is about the Texinfo documentation you can invoke with info grub. (Also online). Compared to their info counterparts, man pages for GNU software (see e.g. man -k grub) are often quite terse. – fra-san Mar 28 at 18:09
  • @ctac_ thanks for the suggestions! I tried that but nothing changed :/ – Ju Ko Mar 29 at 12:02
  • 1
    @GAD3R This worked! Thanks a lot! If you post as an answer, I can accept it as the right one. – Ju Ko Mar 29 at 14:04
1
+50

You should set GRUB_RECORDFAIL_TIMEOUT=0 in your /etc/default/grub then run update-grub.

info -f grub -n 'Simple configuration' | less  -p 'GRUB_RECORDFAIL_TIMEOUT'
'GRUB_RECORDFAIL_TIMEOUT'

If this option is set, it overrides the default recordfail setting.
 A setting of -1 causes GRUB to wait for user input indefinitely.
 However, a false positive in the recordfail mechanism may occur if
 power is lost during boot before boot success is recorded in
 userspace.  The default setting is 30, which causes GRUB to wait
 for user input for thirty seconds before continuing.  This default
 allows interactive users the opportunity to switch to a different,
 working kernel, while avoiding a false positive causing the boot to
 block indefinitely on headless and appliance systems where access
 to a console is restricted or limited.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.