I have added the debug parameter on the kernel command line to enable debug in the kernel, unfortunately this also enables debug in systemd causing my /var/log/daemon.log and /var/log/debug to fill up with crap leading to out of disk space issues.

I would like to keep debug enabled for the kernel but not for systemd, how can I do this?

1 Answer 1


It seems that the systemd log level can be set on the kernel command line either by the debug parameter or by the systemd.log_level parameter. So one can set the debug parameter first and then follow it with systemd.log_level=info to set systemd logging back to it's normal level.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .