0

I tried to install "ecodms Server" on linux according to the installation manual.

but i have several issues installing the software, which leads me to the assumption that i am missing in general some dep sources in etc/apt/sources.list

When i try to install the software, I'll get following info (in german)

Die folgenden Pakete haben unerfüllte Abhängigkeiten: ecodmsserver : Hängt ab von: libqt5sql5 soll aber nicht installiert werden Hängt ab von: libqt5xml5 soll aber nicht installiert werden Hängt ab von: libqt5sql5-psql soll aber nicht installiert werden Hängt ab von: postgresql soll aber nicht installiert werden Hängt ab von: samba soll aber nicht installiert werden Hängt ab von: postgresql soll aber nicht installiert werden Hängt ab von: oracle-java8-unlimited-jce-policy ist aber nicht installierbar oder openjdk-8-jre soll aber nicht installiert werden Hängt ab von: libapr1 ist aber nicht installierbar haveged : Hängt ab von: libhavege1 (>= 1.9.0) ist aber nicht installierbar

i am on debian 9 strech. It says depends on but should not be installed or depends on and is Not installable. I tried to install them individually but with no success

ANy ideas how i can fix this?

Note: replaced the hashtag-char wir (hashtag), since the lone Would be bold$

sources.list

# (Hashtag) deb cdrom:[Debian GNU/Linux 9 Stretch - Official Snapshot amd64 LIVE/INSTALL Binary 20170621-14:43]/ stretch contrib main non-free

(hashtag)deb cdrom:[Debian GNU/Linux 9 Stretch - Official Snapshot amd64 LIVE/INSTALL Binary 20170621-14:43]/ stretch contrib main non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free

deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

deb http://www.ecodms.de/ecodms_180964/stretch /

0

As I could install haveget on my other system (SparkyLinux, also Debian based) and compared the sources list, I added following missing entries:

deb http://ftp.debian.org/debian/ testing main contrib non-free 
deb-src http://ftp.debian.org/debian/ testing main contrib non-free 
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

then I executed:

apt-get update
apt --fix-broken install

with those, the installation executed successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.