0

I have installed CentOS 7 on dual boot on an 10ish-year-old Toshiba Qosmio laptop which came with Windows 7.

I did the minimal install, yum update, then installed the "GNOME desktop" group package and started GNOME via startx. It worked for some seconds, then it froze when I selected the options for power management.

After reboot, it asks the LUKS password, it shows the GNOME prompt to select the user, then the screen stays black while the CPU fan turns like mad. After a few minutes the CapsLock key light starts blinking.

I've tried to boot at GRUB with a previous kernel version but it does the same, except for the CapsLock key light.

The laptop has a Nvidia GEForce GTX 560m, might the cause be a wrong graphic driver?


EDIT 22/3: I removed the nouveau driver and installed the appropriate Nvidia graphic driver as described here. System is set to boot to multi-user.target.

Now when I run startx the screen goes black for a split second and then outputs the following error:

xauth:  file /home/dr/.serverauth.6309 does not exist


X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
Build Operating System:  3.10.0-957.1.3.el7.x86_64
Current Operating System: Linux hackbox 3.10.0-957.10.1.el7.x86_64 #1 SMP Mon Mar 18 15:06:45 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-957.10.1.el7.x86_64 root=UUID=3a27c3be-ea50-4548-92db-53879292b3aa ro rd.luks.uuid=luks-fac75b1c-2869-4923-8ff1-0e7e7e868dd3 rd.luks.uuid=luks-735bf876-be70-40a4-ac81-f6c6ab46b542 rhgb quiet nouveau.modeset=0
Build Date: 14 March 2019  10:37:36AM
Build ID: xorg-x11-server 1.20.1-5.3.el7_6
Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 23 11:40:25 2019
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

Here are the relevant lines from /var/log/Xorg.0.log, reporting only the lines with warnings or errors:

(...)
[   409.722] (II) modeset(0): using drv /dev/dri/card0
[   409.722] (WW) Falling back to old probe method for fbdev
[   409.722] (II) Loading sub module "fbdevhw"
[   409.722] (II) LoadModule: "fbdevhw"
[   409.722] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[   409.723] (II) Module fbdevhw: vendor="X.Org Foundation"
[   409.723]    compiled for 1.20.1, module version = 0.0.2
[   409.723]    ABI class: X.Org Video Driver, version 24.0
[   409.723] (EE) [drm] Failed to open DRM device for (null): -2
[   409.724] (II) modeset(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[   409.724] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[   409.724] (==) modeset(0): RGB weight 888
[   409.724] (==) modeset(0): Default visual is TrueColor
[   409.724] (II) Loading sub module "glamoregl"
[   409.724] (II) LoadModule: "glamoregl"
[   409.725] (WW) Warning, couldn't open module glamoregl
[   409.725] (EE) modeset: Failed to load module "glamoregl" (module does not exist, 0)
[   409.725] (EE) modeset(0): Failed to load glamor module.
(...)
[   409.766] (II) Initializing extension GLX
[   409.766] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
(...)

and the output of lsmod | grep nvidia :

nvidia_drm             39676  0
nvidia_modeset       1108588  1 nvidia_drm
nvidia              14368631  1 nvidia_modeset
ipmi_msghandler        56032  2 ipmi_devintf,nvidia
drm_kms_helper        179394  3 i915,nouveau,nvidia_drm
drm                   429744  6 ttm,i915,drm_kms_helper,nouveau,nvidia_drm

EDIT 28/3: It seems that glamoregl is part of the ATI driver framework and does not work with Nvidia. So I uninstalled xorg-x11-glamor (and had to reinstall xorg-x11-server which was deleted as a dependency).

The X log reported errors about missing fbdev and vesa drivers, so I installed xorg-x11-drv-fbdev-0.5.0-1.el7.x86_64 and xorg-x11-drv-vesa.x86_64.

I also installed xorg-x11-drv-nouveau.x86_64 and reenabled it from the kernel options in GRUB.

Now startx correctly starts Gnome but it doesn't accept any keypress or mouse input. Gnome however is functional, because the clock in the upper right corner works, and I can run commands on this X instance by ssh'ing to the laptop from a different computer and launching GUI programs by specifying the target display, e.g.:

DISPLAY=:3 gedit

which opens the Gedit application on the laptop screen.

Note that the X log doesn't contain any error, only a warning:

[   197.636] (WW) Falling back to old probe method for fbdev
  • Now that you've removed glamoregl, maybe you can try with nouveau instead of the nvidia driver ? – Pierre-Alain TORET Mar 26 at 15:15
  • Done, nothing changes. – dr01 Mar 28 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.