0

I've experienced a sudden error when trying to run zypper by any form:

zypper: symbol lookup error: /usr/lib64/libzypp.so.908: undefined symbol: gzdopen

Not very sure how to fix that, since the latest package of libzypp is asking me for tons of dependencies when i try to install it:

sudo rpm -i --force http://widehat.opensuse.org/opensuse/update/leap/15.0/oss/x86_64/libzypp-17.6.4-lp150.2.3.1.x86_64.rpm

error: Failed dependencies:
        libboost_thread.so.1.66.0()(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libc.so.6(GLIBC_2.14)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libc.so.6(GLIBC_2.15)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libc.so.6(GLIBC_2.16)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libcrypto.so.1.1()(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libproxy.so.1()(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        librpm.so.8()(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libsolv-tools = 0.6.35 is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libstdc++.so.6(GLIBCXX_3.4.18)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libstdc++.so.6(GLIBCXX_3.4.19)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libstdc++.so.6(GLIBCXX_3.4.20)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libstdc++.so.6(GLIBCXX_3.4.21)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libstdc++.so.6(GLIBCXX_3.4.22)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libudev.so.1()(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        libudev.so.1(LIBUDEV_183)(64bit) is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by libzypp-17.6.4-lp150.2.3.1.x86_64
  • By what I understand, I'm not even able to update libzypp like that, since it gives a weird dependence with rpmlib.... Any ideas? – stonebird Mar 25 at 10:08
0

Closing the question. Apparently the entire /usr - related configuration of the system was broken, so I had to go for a backup.

Nothing worked as to solve the zypper crash - it seems that at some point when installing libraries/modules a non-compatible version was forced, which led to irreparable damage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.