2

A week ago, a yum update on all my Rehdat 7 servers, outputs the following error:

Error:

Failed to retrieve group file for repository: rhel-x86_64-server-7

I tried doing a yum clean all, but that did not work.

I suspect it's a problem with the the satellite redhat software server that we use here. I registered a totally new node with that server, but the same error occurs.

A yum check-update after clean all with debugging on shows it tries to download the file but fails. But downloads all the other files.

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, : subscription-manager Adding en_US.UTF-8 to language list Updating Subscription Management repositories. Unable to read consumer identity Config time: 0.072 This system is receiving updates from RHN Classic or Red Hat Satellite. Yum version: 3.4.3 rpmdb time: 0.000 Building updates object Setting up Package Sacks rhel-x86_64-server-7 | 1.5 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/group | 770 kB 00:00
rhel-x86_64-server-7/primary | 33 MB 00:03
rhel-x86_64-server-7 23361/23361 rhel-x86_64-server-7-rhscl-1 | 1.5 kB 00:00
rhel-x86_64-server-7-rhscl-1/group | 104 B 00:00
rhel-x86_64-server-7-rhscl-1/updateinfo | 915 kB 00:00
rhel-x86_64-server-7-rhscl-1/primary | 3.1 MB 00:00
rhel-x86_64-server-7-rhscl-1 10948/10948 rhel-x86_64-server-7-thirdparty-oracle-java | 1.5 kB 00:00
rhel-x86_64-server-7-thirdparty-oracle-java/group | 104 B 00:00
rhel-x86_64-server-7-thirdparty-oracle-java/updateinfo | 15 kB 00:00
rhel-x86_64-server-7-thirdparty-oracle-java/primary | 129 B 00:00
rhel-x86_64-server-extras-7 | 1.5 kB 00:00
rhel-x86_64-server-extras-7/group | 104 B 00:00
rhel-x86_64-server-extras-7/updateinfo | 241 kB 00:00
rhel-x86_64-server-extras-7/primary | 317 kB 00:00
rhel-x86_64-server-extras-7 1076/1076 rhel-x86_64-server-optional-7 | 1.5 kB 00:00
rhel-x86_64-server-optional-7/group | 31 kB 00:00
rhel-x86_64-server-optional-7/updateinfo | 2.0 MB 00:00
rhel-x86_64-server-optional-7/primary | 4.3 MB 00:00
rhel-x86_64-server-optional-7 17521/17521 rhel-x86_64-server-rh-common-7 | 1.5 kB 00:00
rhel-x86_64-server-rh-common-7/group | 104 B 00:00
rhel-x86_64-server-rh-common-7/updateinfo | 29 kB 00:00
rhel-x86_64-server-rh-common-7/primary | 55 kB 00:00
rhel-x86_64-server-rh-common-7 235/235 rhel-x86_64-server-supplementary-7 | 1.5 kB 00:00
rhel-x86_64-server-supplementary-7/group | 40 kB 00:00
rhel-x86_64-server-supplementary-7/updateinfo | 56 kB 00:00
rhel-x86_64-server-supplementary-7/primary | 112 kB 00:00
rhel-x86_64-server-supplementary-7 310/310 rhn-tools-rhel-x86_64-server-7 | 1.5 kB 00:00
rhn-tools-rhel-x86_64-server-7/group | 104 B 00:00
rhn-tools-rhel-x86_64-server-7/updateinfo | 15 kB 00:00
rhn-tools-rhel-x86_64-server-7/primary | 24 kB 00:00
rhn-tools-rhel-x86_64-server-7

  • Do you know what version of Satellite software you're using? – John Mar 21 at 17:18
  • Can you add your repo files from /etc/yum.repo.d/ ?? – Vivek Kanadiya Mar 21 at 17:21
  • also include output of /etc/yum/pluginconf.d/rhnplugin.conf – Deeh Mar 21 at 18:29
  • @VivekKanadiya There is nothing in yum.report.d other than the redhat generated file, which just contains comments, because it's receiving the repos from the satellite server. – user1993015 Mar 22 at 4:12
  • @Deeh rhnplugin.conf just contains:[main] enabled = 1 gpgcheck = 1 timeout = 120 – user1993015 Mar 22 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.