1

I'm on Arch Linux + GNOME 3.32 + Wayland

I want the touchpad to be disabled when an external mouse is connected. I know there's a great extension for this that I've been using for long time, but it is currently (at time of writing) not working with GS 3.32 yet. So, I discovered that it can also be done via dconf:

To do so, I run dconf editor and set /org/gnome/desktop/peripherals/touchpad/send-events to disabled-on-external-mouse

That works perfectly, however it is reset to enabled everytime I restart my GNOME session. How do I make it persistent?

EDIT: I have found a workaround; see my answer below

0

Ok, as a workaround I added the following to ~/.bashrc file:

dconf write /org/gnome/desktop/peripherals/touchpad/send-events "'disabled-on-external-mouse'"

This is executed at every login and restores the wanted settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.