1

I followed this tutorial on how to encrypt my home folder. I imported the stash into the gnome-gui tool and without thought clicked on the "mount" checkbox. As expected, encfs now started to encrypt the folder and will unmount when it's finished. I didn't fully realize what I was doing (Yes, there were a few large linux ISOs in there and unmounting home from a running system is stupid) and now the encryption has been running for almost 24 hours and it's still not even halfway done. What's weird is that encfs is barely using any CPU.
Now I'm not sure what to do since I'm afraid that I will lose my data if I just kill the process or shutdown my machine.

EDIT: Here are the steps I took.

  1. With this tool I added a new stash with the options shown in the screenshots. enter image description here Please note that I chose different paths (aka my home directory as seen in the last screenshot)

enter image description here enter image description here enter image description here

  1. Clicked on the "mounted" checkbox enter image description here

EDIT2: the /home/.janine directory did not exist before and the encfs-manager was called as a normal user without sudo

  • which stash did you import to where ? what is the gnome-gui tool I have never heard of ? Please describe the exact steps you took (add the commands you entered, attach screenshots if necessary). – pLumo Mar 21 at 8:32
  • I added some more description and all configurations to the post – Janine Mar 21 at 8:41
  • I see ... I think, this tool is not meant to encrypt your home directory, but just encrypt a directory as a secure data store. /home/janine existed before and is your unencrypted home directory? What about /home/.janine ? Did it exist before ? – pLumo Mar 21 at 8:48
2

This tool is not meant to encrypt your home directory. Actually, it will not encrypt anything when you click on mount (thus no CPU activity).

Once you mounted a directory, files get encrypted on the fly when you write them to the mount folder. The encrypted files then get saved encrypted in the stash directory.

What happened to you, I think, is that the mount to your /home folder failed, but the tool did not take notice of it (or the tool worked and you did not notice). Untick the "Mounted" checkbox. If that does not work, stop the process.

Then, remove the entry from the EncFS manager (and probably remove the tool completely, as EncFS is not considered save).

If you cannot access your home folder now, open a terminal and enter:

fusermount -u /home/janine

If that does not work, restart your machine.


Don't use EncFS, what then?

  • Encrypting home is usually done with ecryptfs not EncFS.
  • Encrypting full computer, use Luks.
  • A safe datastore is better done with an encrypted container or second partition/hdd using Luks (Linux only) or Veracrypt (platform-independent).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.