0

In my country some websites like twitter,youtube,facebook etc are blocked by government and we have to use VPN so we can access them, but somehow after I connect to VPN (openvpn and PPTP both have this problem) I can ping these websites and can resolve them with nslookup , but when it comes to browsers like chrome and firefox I can't browse some of them. It's really interesting , I can browse youtube perfectly , but twitter won't load complete (here) , facebook doesn't load at all (there are some other websites that won't load at all like facebook) I tried removing the cache of browsers and even with new and fresh installing without any caching this problem appears I change the DNS with /etc/resolvconf/resolvconf.d/head file

PS: I can all websites with their Domain Names

| improve this question | | | | |
  • Look up how to reduce MSS and MTU. With OpenVPN the keyword is mssfix. – roaima Mar 21 '19 at 8:56
  • I would sniff local traffic (mostly DNS and tcp/80+443) and see where's the issue. Maybe MTR tool will be helpful here mtr {facebook ip here}. – Radek Radek Mar 21 '19 at 10:21
  • thanks to you guys , the problem was MTU packets size – Afshin Mar 21 '19 at 10:26
0

I've searched many topics for this problem and I finally resolve the problem , the problem was the size of MTU packets of my Wlan card I reduce it to 1200 ( previous size was 1500 ) with sudo ifconfig wlp2s0 mtu 1200 command ( wlp2s0 is my wireless card) and the problem was solved

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.