1

I'm trying to install https://mfslinux.vx.sk/files/images/10/i386/mfsbsd-10.0-RELEASE-i386.img with PXE so I can install FreeBSD.

Here's my PXE boot menu on server:

LABEL mfsbsd
        MENU LABEL mfsBSD
        kernel memdisk
        append initrd=FreeBSD/mfsbsd-10-i386.img raw

My i386 client machine boots over PXE fine. Because this version of mfsbsd has a known issue with bsdinstall, I'm trying to run the following as described in the previous link:

root@mfsbsd:~ # mkdir -p /usr/freebsd-dist && cd /usr/freebsd-dist
root@mfsbsd:~ # pkg install -y curl

Upon which I get "No more space left" error midway through the curl download.

I see /dev/md0 is only 28MB with 2MB free space. I'm thinking if that memdisk could be made bigger, I could install FreeBSD without issues. What's the workaround?

1

A few assumptions:

  1. You are aware that you are installing an ancient version?
  2. You are aware that 10.0 is not available from freebsd.org? (9.3 and 10.1 are)
  3. You are sure you want the 32 bit (i386) and not 64 bit (amd64) version?
  4. You are aware that freebsd comes with the fetch utility and do not need curl?

When using mfsbsd the absolutely easiest path is to use the "special edition" as it contains base.txz and kernel.txz:

https://mfsbsd.vx.sk/files/iso/10/i386/mfsbsd-se-10.0-RELEASE-i386.iso

And if memory serves me right mfsbsd had the zfsinstall script in 10.0. It is quick and simple to use as described on the homepage

zfsinstall -d /dev/ada0

As for the "known issue" you reference you cut'n'paste too quickly. The poster (amontalban) who suggested using curl to get all sources are referencing another page which describes the full process. And they're building a mfsbsd image from scratch.

The easy workaround was earlier in the thread:

root@mfsbsd:~ # mkdir -p /usr/freebsd-dist/ 
root@mfsbsd:~ # touch /usr/freebsd-dist/MANIFEST

This creates an empty MANIFEST file. The error that you get from bsdinstall is that this file cannot be found. The poster (panaceya) then claims the installation can continue with an empty file.

If you want the proper file then get it from your own 10.0 source as they are not avaiable on freebsd.org.

If you step up the version to 10.1 (or something else) you can get the proper file directly rather than using touch:

fetch http://download.freebsd.org/ftp/releases/i386/10.1-RELEASE/MANIFEST

The content of the file is:

base.txz    8cbe70ff3022b63f19ec254b989cc61daaa56c47938a38951818e8f3d68f5a2c    19491   base    "Base system (MANDATORY)"   on
doc.txz b3c7fcbbc74fd9861164873ffe8011ba86bd9d25d83ebf7f401f32de02a4f4f1    121 doc "Additional documentation"  off
games.txz   4bb792e2411782c1359fa7bf0676400f97fcb888a523c1e5bd1005b2643a89d8    53  games   "Games (fortune, etc.)" on
kernel.txz  84c35f34e1fdf16a5c2d9b3400e0358157d14b5e4a56deb11ece54a8623b3cb9    1588    kernel  "Kernel (MANDATORY)"    on
ports.txz   6bd4fb4da570f7ae38894320ef33fda88aa628106ea9ab1ffbaa9088b6eead7d    149186  ports   "Ports tree"    on
src.txz f919287a5ef51d4f133f27c99c54f2e8054f408d3dd53bc60f4e233cc75ec03d    65300   src "System source code"    off

So basicly it is checksums for the packages. With an empty (or proper) MANIFEST file bsdinstall should be able to continue using a regular network install.

As for extending the memory disk if you want to go that route (I would not!) then have a look at the FreeBSD Handbook 17.9. Memory Disks. The easiest path is to simply create a new filesystem:

# mdmfs -s 5m md1 /mnt

Also see How can I resize an md device in FreeBSD?. Note that you can resize the memory disk but it is the block device you extend. You then need to deal with the file system afterwards. In this case it is not worth it.

  • @claus-anderson I tried a variety of iso and img in the mfsbsd site. The one that worked was the RELEASE 9 iso. A trick I used was to only download the base and the kernel so bsdinstall would not be killed by a lack of swap space. I cleaned up earlier comments, and again thank you for your time! I do have to tell you I could download all the base, doc, games, kernel, ports files in a VM however, and the bsdinstall went through without issues. I'm thinking this is because my P III machine only has 512MB of memory. zfsinstall would also be killed complaining lack of swap space. – Regmi Mar 22 '19 at 19:02
  • 1
    So in summary, if you use "fetch" and only download "base.txz" and "kernel.txz" as described above, one could run bsdinstall in a memory strapped and old hardware. – Regmi Mar 22 '19 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.